Been getting frustrated with this so I hope someone can help. I think it’s an easy fix in the .htaccess file.

I’ve been trying to implement a wildcard SSL certificate to my members portal.

My main domain is www.rawtillwhenever.com the subdomain is members.rawtillwhenever.com

I built the main domain without a security certificate and just added it to it today. I purchased a wildcard certificate through Bluehost and then used the wordpress plugin “Really Simple SSL” to add it to the site.

I’ve changed the site url on the members portal to include https but it (https//members.rawtillwhenever.com) keeps redirecting to https//rawtillwhenever.com

If I try to go to http//members.rawtillwhenever.com (without the https) it still redirects to https//rawtillwhenever.com

I’ve contacted bluehost support and they just gave me this document here.
https://my.bluehost.com/cgi/help/766

The main domain is in a subfolder /public_html/rawtillwhenever/ and the subdomain is in /public_html/rawtillwhenever/members/

When I use a http/https header check, it returns this:

HTTP/1.1 301 Moved Permanently => 
Date => Sun, 14 May 2017 20:04:11 GMT
Server => Apache
Location => https://www.rawtillwhenever.com/
Cache-Control => max-age=3600
Expires => Sun, 14 May 2017 21:04:11 GMT
Vary => Accept-Encoding,User-Agent
Content-Length => 0
Connection => close
Content-Type => text/html; charset=UTF-8

The .htaccess file for the subdomain is:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

If anyone can help me, that’d be great otherwise I’d pay for your time to fix it.

Read more here: HTTPS subdomain keeps redirecting to HTTPS main domain


Solution:

If you know the solution of this issue, please leave us a reply in Comment section, to update the question.


Wordpress related questions and answers: