I recently switched from Squarespace to WordPress. I am currently using the Bridge theme, but this comes with Visual Composer. I don’t really like VC, so I tried installing Beaver Builder instead. However, I get some errors in the console when starting the Page Builder. This impact the Page Builder as I cannot use text editor. I can’t type text in the text editor & also the icons above the text area frame are not visible.

Below, you can see the errors:

"Uncaught Error: no such method 'instance' for menu widget instance" op rij 2 van {bestand}.

Error: no such method 'instance' for menu widget instance
    at Function.error (http://www.petasos.be/wp-includes/js/jquery/jquery.js?ver=1.12.4:2:1814)
    at HTMLUListElement.<anonymous> (http://www.petasos.be/wp-content/themes/bridge/js/plugins.js?ver=4.7.5:38:8376)
    at Function.each (http://www.petasos.be/wp-includes/js/jquery/jquery.js?ver=1.12.4:2:2881)
    at a.fn.init.each (http://www.petasos.be/wp-includes/js/jquery/jquery.js?ver=1.12.4:2:846)
    at a.fn.init.$.fn.(anonymous function) [as menu] (http://www.petasos.be/wp-content/themes/bridge/js/plugins.js?ver=4.7.5:38:8111)
    at $.(anonymous function).(anonymous function)._create (http://www.petasos.be/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.11.4:11:2191)
    at $.(anonymous function).(anonymous function)._create (http://www.petasos.be/wp-content/themes/bridge/js/plugins.js?ver=4.7.5:38:6664)
    at $.(anonymous function).(anonymous function)._createWidget (http://www.petasos.be/wp-content/themes/bridge/js/plugins.js?ver=4.7.5:38:9651)
    at new $.(anonymous function).(anonymous function) (http://www.petasos.be/wp-content/themes/bridge/js/plugins.js?ver=4.7.5:38:5990)
    at HTMLInputElement.<anonymous> (http://www.petasos.be/wp-content/themes/bridge/js/plugins.js?ver=4.7.5:38:8796)"

As the error states there are some issues with my plugins.js & I deactivated this file. Next, Beaver Builder works. But when I disable this file, a lot of JS effects on the website do no longer function.

Does anyone have experience with this kind of error? I think it is related to a jQuery version conflict, but I am not sure? If you need more information, ask & I’ll provide.

Read more here: jQuery conflict causing errors?


Solution:

If you know the solution of this issue, please leave us a reply in Comment section, to update the question.


Wordpress related questions and answers: