php 7.0 update to 7.1 and at least 7.2

i want to upgrade WP’s php from the 7.0 version to the 7.2 at last .

for instance , SG optimizer give me errors while trying to upgrade to php 7.1

these are the ones :

The following plugins/themes are not compatible with PHP 7.1.

Html5 Audio PlayerSee Errors
FILE: /var/www/html/wp-content/plugins/html5-audio-player/inc/follow.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

FILE: /var/www/html/wp-content/plugins/html5-audio-player/inc/custom-offer.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

FILE: /var/www/html/wp-content/plugins/html5-audio-player/cmb2/js/index.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

FILE: /var/www/html/wp-content/plugins/html5-audio-player/cmb2/css/index.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

FILE: /var/www/html/wp-content/plugins/html5-audio-player/cmb2/images/index.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

FILE: /var/www/html/wp-content/plugins/html5-audio-player/cmb2/includes/index.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

FILE: /var/www/html/wp-content/plugins/html5-audio-player/cmb2/index.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

WPForms LiteSee Errors
FILE: /var/www/html/wp-content/plugins/wpforms-lite/includes/analytics/class-monster-insights.php
———————————————————————————————————————————————————————————-
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
———————————————————————————————————————————————————————————-
1 | WARNING | No PHP code was found in this file and short open tags are not allowed by this install of PHP. This file may be using short open tags but PHP does not allow them.
———————————————————————————————————————————————————————————-

End Report 1528548781

i don’t know what to do ? and what to believe ? are these errors serious ?

can i upgrade anyway ? what to do in a case of a safe upgrade to php 7.1 and php 7.2 ? and what not to do ?

in simple ways if possible …

i have to tell you that i already have php 7.2 installed on my machine and it seems to work perfectly but the WP’s php is still the 7.0 , normal ?

greetings .

Read more here:: php 7.0 update to 7.1 and at least 7.2

Leave a Reply

Your email address will not be published. Required fields are marked *