Pre-emptive problems with PHP upgrade and WordPress function

so I quite frequently use the function wp_get_attachment_src with the array index declared on the end, like wp_get_attachment_src(1, ‘full')[0]; when I assign it to a variable, just because it is more convenient.

I seem to remember trying to do this before, maybe on a different version of php, or maybe it was set to strict mode; and it threw an error up.

My server is being upgraded from PHP 5.4 to 5.6 very soon, and I was wondering if anyone was aware of this causing any problems or could suggest any guides that might help highlight any potential risks the upgrade might bring.

Thanks!

Read more here: Pre-emptive problems with PHP upgrade and WordPress function

Leave a Reply

Your email address will not be published. Required fields are marked *