Router blocking WordPress media files and plugin uploads

I have a somewhat peculiar issue that I cannot figure out. I’ve spent countless hours on the phone with both my web host and my ISP. The issue is that I can’t upload pictures to WordPress. I drag and drop it, and it takes at least 10-15 minutes for a single 200kb image to upload. Speed isn’t the issue, as I can stream Netflix. It’s not device-specific as it happens to all of my devices. I can upload to my other WordPress site on GoDaddy, but not to WebHostingHub. It’s not related to the server, since I can upload to my WordPress via my mobile data plan. It’s also not the server, because I can use FTP with no problem. I can also access it from my work computer without an issue and upload from that network.

I believe something in my router is causing it to be blocked. I’m not sure if I need to open a specific port or if there’s a firewall that’s blocking it. It only happened within the last two weeks, because I could upload everything fine before. The page loads fine, however. The trace route times out on hops 12-15, but completes on hop 16.

I’m literally pulling my hair out. It’s an Actiontec C1000a. Ports that show up are HTTP(80) and 137. Port forwarding and unblocking both ports seem to have no effect. Am I missing something? Any help would be greatly appreciated.

EDIT: wp-admin/async-upload.php net::ERR_CONNECTION_RESET
It only happens from my home network.

Read more here: Router blocking WordPress media files and plugin uploads

Leave a Reply

Your email address will not be published. Required fields are marked *