I’ve been stuck with this error since yesterday. Whenever I use –watch or when manually compiling my scss. I’m currently using it for the custom theme development of a WordPress site. Tried uninstalling/reinstalling SASS but it’s not helping. Here’s what it returned to me when I used –trace as recommended:

/Library/Ruby/Gems/2.0.0/gems/sass-3.4.23/lib/sass/exec/base.rb:28: stack level too deep (SystemStackError)

My suspicion is that I nest the elements too much. Is there a limit when nesting on SASS? Do you have any other fixes that I can try? I’ll really appreciate it. I don’t really wanna go back to manually writing my CSS for this project.

Read more here: SASS SystemStack Error: stack level too deep


Solution:

If you know the solution of this issue, please leave us a reply in Comment section, to update the question.


Wordpress related questions and answers: