Vagrant / Homestead local WordPress site – infinite waiting for website.local (sockets for non existing files)?

I’m facing annoying issue that prevents me from accessing WordPress website (dashboard wp-admin works fine until I go to Media).

The problem is that all static images are now references as:

http://website.local/wp-content/uploads/example_01.jpg
http://website.local/wp-content/uploads/example_02.jpg
http://website.local/wp-content/uploads/example_03.jpg

This would be correct but wp-content/uploads is empty. It was added to .gitignore to prevent versioning static images. So as soon as I try to open this (correct but non existing) resource, the browser hangs.

I mean, it doesn’t hang. In other tabs I can open other domains but nothing from website.local domain works. I have to vagrant halt and then vagrant up to make it still work.

I can still ping and I get

PING website.local (192.168.10.10): 56 data bytes
64 bytes from 192.168.10.10: icmp_seq=0 ttl=64 time=0.280 ms
64 bytes from 192.168.10.10: icmp_seq=1 ttl=64 time=0.305 ms

but Chrome says in bottom left

Waiting for website.local…

I trier to ssh and check logs in /var/log/nginx/ or any error.logs but I could not find anything useful. I will try to upload images once I get them but assuming it won’t happen, how I can prevent that. Is this related to allowed sockets?

Thanks for your help.

Read more here: Vagrant / Homestead local WordPress site – infinite waiting for website.local (sockets for non existing files)?

Leave a Reply

Your email address will not be published. Required fields are marked *