enter image description here

I have been working with a client to migrate a site to a new host provider. I migrated the db manually, and have run into an issue that I have never seen before. I can edit ALL existing posts, but when I try to create a new post – in the Permalink field, under “Enter title here” I see:
Permalink: ?preview=true

When I publish or save the draft, I receive: Sorry, you are not allowed to edit this post.

Also, on the posts, there is no preview button.

Steps taken in order to try to fix:

  • I have turned on WP_debug, which was little help for this issue.

  • I switched my theme to 2017 to see if there were theme conflicts occurring, no help.

  • I disabled all plugins after switching the theme, no help.

  • I compared my wp_capablities row in wp_usermeta to other existing wp_capabilities row;

  • I did try a sql statement to replace the admin cap, i.e.:

  • UPDATE wp_usermeta
    SET meta_value = REPLACE( meta_value, ‘a:1:{s:13:”administrator”;s:1:”1″‘,’a:1:{s:13:”administrator”;b:1’ );

    So now my admin cap is set to: a:1:{s:13:”administrator”;b:1′ )

    But I am still receiving the same results.

    I was hoping someone might recognize this error and be able to point out where I screwed up.

    Thx!
    Chipleh

    Read more here: WordPress 4.7.4 – Can’t publish new posts


    Solution:

    If you know the solution of this issue, please leave us a reply in Comment section, to update the question.


    Wordpress related questions and answers: